Would be good to use a repo other than Ubuntu's for MongoDB


#1

Ubuntu’s own repo for MongoDB is great and all but it’s never updated regularly which means the version you have on your containers is like 2.6 which is not good (MongoDB is on 3.2 and there are a lot of differences between versions).

It would be awesome to use the official MongoDB Inc repo as found in their docs: https://docs.mongodb.org/manual/tutorial/install-mongodb-on-ubuntu/


#2

Feel free to install the latest version of MongoDB in your workspace. You have root access so can install anything you like.


#3

This is definitely something that could be worked into a workspace if you’d like to make a PR to the Cloud9 workspaces repo. They’re all built on Docker files so it’ll take a little bit of Docker knowledge.


#4

I actually cannot follow the tutorial, it seems to break dpkg on the container. I do believe that it is some kind of conflict between the installed package and the official MongoDB Inc package occurring.

I did raise a support ticket for it about a day and a half ago, however, it has not been looked at .

But if you follow the MongoDB Inc tutorial you will see the break when you install the mongodb-org package.

As for adding the template: I still have not had a good chance to dig into the internals of docker yet and to actually program it (it is on my list of 100 things :P) but I will have a go at it but don’t expect much, heh.


#5

We did some troubleshooting and came to a few conclusions here.

  • Following the Mongo install tutorial listed above works now
  • Be sure to specify the version (3.2) as mentioned in the doc otherwise it may default to 2.6.
  • After some testing, we were not able to consistently break dpkg

If you find other results then please post them and we can troubleshoot and dig in :wink: