Workspace went missing


#1

Hi, I was working on a workspace over the holiday and when I came back this morning (after not having worked with it for a couple weeks) it was gone from my account and in its place was the demo workspace. I’m fairly certain that this is the correct account (the one associated with my Github profile) and that I didn’t delete the workspace myself. Any help in recovering the workspace or at least the files from the workspace would be immensely appreciated. The workspace should be called something like “fellowship-map”.

Cheers,
Daniel


Workspace missing
#2

It’s returned this morning as mysteriously as it disappeared. Thanks if somebody did something.


#3

@maxsond looks like you accidentally created a second account. This is pretty common and easy to do. Here’s generally what happens:

  1. I sign up for an account.
  2. I forget that I’ve never connected my Cloud9 account with Github.
  3. I sign into Cloud9 with GitHub.
  4. No account is attached to my Github user so a new Cloud9 account is created.
  5. I now have two separate account but in this one I just see the demo workspace.

If this occurs, sign out of your current account then sign in with whatever service you’re trying to connect. At this point, you may be asked for an email address and you can just put in any email that’s not already associated with a Cloud9 account (it can even be made up). Now you’ll just want to delete that second account completely.

Once you’ve done this, you can now log into your original Cloud9 account and run through the guide to link your GitHub account to your desired Cloud9 account.


#4

Yeah, I realized that and tried logging out of the standalone account and into the one linked to GitHub. I may have simply messed up at that point and logged back into the standalone account again. Now that I see it again I’ll go ahead and delete the standalone account to prevent this confusion in the future. Thanks!