Workspace stuck on 'archiving' after apt-get upgrade


#1

Hi team,

I tried to upgrade some packages on Ubuntu and then decided to resize the disk. Now my workspace seems to be stuck in the ‘archiving’ state. I have quite a bit of unsaved changes and would not want to lose these. I PM’d Nikolai, but if he is not available, could someone else help?

Thanks


#2

Looks like it’s been resolved. Thanks for any help!

EDIT: nope, now it’s back to archiving. What’s going on?


#3

Ok, since the workspace fell into an endless ‘archiving’ loop, I managed to salvage the sources (before it started ‘archiving’ again) and just created a new one. For anyone in the future struggling with this, here are a few tips:

  1. Make sure to backup sources to your local machine before messing around with system packages(!)

  2. DON’T run apt-get upgrade. The warning says that it is not recommended due to space constraints, but I’d also add that it is outright dangerous, since my workspace failed once I ran the upgrade and decided to add more space.

  3. If you do need to upgrade/rebuild some packages (which in my case was adding support for OpenSSL instead of GnuTLS for Git, which was unfortunately required by AWS CLI credential helper - see here, which by itself would have already been satisfied if the workspace ran on 16.04 instead of 14.04), then do that piece by piece, and don’t run (1) first.

Hope that helps.