Workspace showing wrong used DISK space

workspace

#1

Here is the workspace url: https://ide.c9.io/wantedboy420/test

I only have less than 500MB data in workspace but when i click at the statistics widget on top right side, it shows me more than 4GB is consumed. I work on selenium python and whenever i run the script, each time 10-20 MB is added. This way it wnt from 2500MB to 4000MB in just 1 day. Please check it.

I could jsut make new workspace but this one has 1GB ram and all the selenium tasks require good amount of ram so this workspace is very important for my projects.

NOTE: actually i have less than 200MB data in workspace.

regards,
mansoor - wantedboy420


#3

As far as I’m aware, the quota on the top right is actually based on interaction (write, possibly read) onto the disk, not necessarily the size on disk.


#4

so what does it mean?


#5

as far as i know, my disk interaction can’t be 20-30 MB for running a python script.


#6

I believe it means there’s been a lot of disk I/O (installing packages, probably)


#7

no there has not been to many in the last few months. its 4500MB+ now and i am just running a selenium script and i can see 20-30 MB added to disk space by just one 1 which is opening 1 link.


#8

its turns out that afterall it was not related to I/O or anything like that. there was alot of temporary data generated by selenium in /tmp folder. so i ran these commands and i am back to 848MB.

cd /tmp/
rm -r *

also added a cron job so it wont happen again.