Workspace previews are often unreachable


#1

Hi,

I have been using c9 for years.
It works great with good performance and I love it.

However since last month I occasionally observed that I cannot open my dashboard and any workspace.
I used Chrome browser and it simply shows timeout error in HTTP connection.
Usually this recovers after a few minutes.
But after running normally for a few minutes, it becomes unreachable again.

I tried incognito mode, disabling all chrome extensions, connect from another network, but all the same.

Is there any changes in c9?
Or is there anything I can help from my side?

Many thanks.


#2

Hi,
We have heard about similar issues from a user from China, but the issues went away when using vpn.
Where are you based at?


#3

I am from Hong Kong.
I think Hong Kong doesnt have the great firewall.
But I will try using a VPN.


#4

Just want to raise that I have the same issue here from Hong Kong.
It takes some minutes to reach any workspace and it is quite annoying.


#5

Similar issues on our side but we’re in South Africa. We also have team members in Croatia with similar issues and it’s becoming quite challenging to get our work done efficiently, which is a real pity as C9 is a really awesome tool.


#6

It seems that this is not a problem of specific locations.


#7

Looks like some ISPs started blocking some of cloud9 ip addresses because of users running phishing sites from their workspaces a while ago.

Please try to contact your ISP, they should be able to unblock cloud9 ips for you.


#8

Thanks for your reply.
But I still doubt whether this is the real cause.

The first thing I notice is that those IPs are not always blocked.
I can connect to my workspace after a while.
I dont think ISPs block IP only for a couple of minutes if they think the site is dangerous.

Moreover, I have this observation:
I have workspaces 1 and workspace 2 running on IP 104.155.203.100 (I guess all workspaces share the same “gateaway” IP).
When timeout happens on workspace 1, workspace 2 is reachable.

And timeout happens not only in preview and workspace, but also the dashboard and login page.

Thanks in advance.


#9

Same, also in Hong Kong. I reported this several weeks ago, but still encountering it - when I tried to cancel my subscription just now I hit a timeout error, lol.


#10

We’ve heard from multiple users that there are issues with PCCW in Hong Kong specifically; if they are your ISP, I’d recommend reaching out to them (if they have any concerns, they may reach out to us at security@c9.io). Some users have found success using VPNs as well if you have access.


#11

I’m also having issues, with any page from c9 domain timing out intermittently.
Have any PCCW customers had any luck with contacting PCCW on this?