Workspace can't be displayed


#1

So my friend and I are planning to develop some stuff so he set up a workspace for me to join. I click open and it takes a while. Finally it comes to a stop only to show a page saying “This page cant be displayed”. I ran some diagnostics but nothing came up. I tried making myself one but I couldn’t even join my own. Could you please help me? My friend and I are really looking forward to developing and this website is the best place to do it.


#2

Hey @wheety3 :slightly_smiling:,

What does the link look like that he shared with you?

It should look something like this:

Please also see the official docs on Sharing a Workspace:

The best place to start sharing is from the dedicated “Share” dialog. Access it via the “Share” button on the right top of the IDE, or via the menu in Window > Share…


If none of the above fixes the issue, can you share the link you’re trying to access or take a screenshot of the page or copy any errors here. :hand: :link:

Best,
Mike
:alien:


#3

Those are the links that don’t display


#4

That link didn’t work for you? It’s a public workspace, it should. What does it do?


#5

" This page can’t be displayed" with a white background and diagnostics


#6

Oh and it works on my phone for some reason but not in my computer


#7

@wheety3 which browser do you use? try with chrome


#8

Well I didn’t think about that. I’ll try that when I’m home


#9

the workspace is not loading
link: https://rails-tutorial-asadjamil.c9users.io/
actually the server is not running


#10

Hey @asadjamil :slightly_smiling:,

That is a link to a app that would be running. However all C9 Workspaces archive themselves:

Cloud 9 IDE is meant to be an IDE, not a web host provider, albeit a Cloud IDE with great Ubuntu terminal access.

You can share the link to the public workspace url (i.e.: https://ide.c9.io/mikeumus/vanilla-js-cal * notice the ide.c9 beginning to this url) easily though and then run the command(s) to fire up your app and then use the Preview features to preview your running app being temporarily hosted for development purposes by C9 from a url looking like the one you shared with us: https://rails-tutorial-asadjamil.c9users.io/

Best,
Mike
:alien: