Why does my downloaded html file look like this?


#1

I’m trying to use files I’ve edited with Cloud9 with my webhost (Namecheap). However, when I downloaded a simple html file as a test and then uploaded it into my file manager at Namecheap, my website, www.christopherdistasio.com, showed line numbers, a settings link, and a JSON toggle. (HTML files I have made in Namecheap’s text editor directly have shown up fine.) Please check out my website to see what I mean. I tried to download then upload from Github directly but the website showed up the same. There’s probably a much easier way to get the files to Namecheap, anyway, and this solution will very likely earn me the not-so-coveted “Newbiest of Newbs” distinction, at least for this year :slight_smile: Thanks for any help you can give.


#2

I’m not exactly sure what problem you’re having. When I go to your website, I see the following:

image

In addition, if I right click on the page and click “View Source,” this is what I see:

image

Is that what you’re seeing? Otherwise, everything is correct (at least the same as your GitHub repo and Cloud9 workspace). If it’s not what you’re seeing, you might try pressing Ctrl+Shift+R to see if a hard refresh will get the correct contents.


#3

Thank you for checking it out and replying, Danny! FYI: I’ve used several devices and I’ve deduced when it is that what I see occurs: when the Cloud9 site is bookmarked in Google Chrome and that browser is being used, no matter if I’m logged in to Cloud9 or not. It doesn’t show up in Google Chrome when Cloud9 is not bookmarked. It doesn’t show up in Microsoft Edge, even with the Cloud9 home page bookmarked in it. Here is a screenshot of what I see, and it looks like what you see in View Source. The middle icon on the far right says “Original JSON toggle”, and the website changes to look correct when it is clicked.


#4

Could you post the entire browser window, including the address bar and bookmarks? I’m still slightly confused as to what this file is open in, and that might help.


#5


#6

The only thing I can think of is that an extension is causing this (given you’re not experiencing the problem in other browsers). Have you tried checking it in incognito or disabling your extensions one by one to figure if it’s one of them?


#7

HI Danny, thank you so much! It did work fine in incognito, and I think it was an extension called JSON VIewer that was causing the problem, because now I can see the website fine in a regular, non-incognito window. Best, Christopher