Where did my workspace go?!

lost-code

#1

I logged on today to continue work through a lesson plan I’m following and my entire workspace is just GONE as if I never made it? I’m not educated enough yet to restore it from GitHub and am feeling pretty anxious at the moment. Did I do something? How can I get back on track without having to start over?


#2

I had a similar experience recently: i had just switched a workspace from public to private and then at some point it disappeared. I freaked out just like you’re probably doing now, but within a relatively short period of time, it suddenly reappeared. Then, just two days ago, when i switched from free to pro-invidual, i created a couple of private ws’s and they also went awol for a short period (don’t remember exactly, but less than an hour). Maybe it’s some kind of manifestation of different datacenters being keep in (eventual) synch??


#3

That is LITERALLY what just happened. It’s back now with no explanation. I guess problem solved but it definitely gives me pause.

Thanks for the reply.


#4

@mdaadvisors @yguyjsoh thank you so much for reporting this and being specific. I’ve raised a flag internally about this and we’ll be looking into it. Updates will be posted here as they come.


#5

Just to be sure, this definitely wasn’t because you accidentally logged in with two separate accounts right?

Sometimes people create an account with their email address then later try to log in with Github/Bitbucket and it actually makes a different account, hence they don’t see their workspaces.

It sounds like this is not the case but I want to be sure of it.


#6

I don’t believe so in that it reappeared on the account I am currently logged into. It was definitely weird.


#7

Alright, I’ll leave this open and visible until we get to the bottom of it. Feel free to report if this happens again. We’ll be looking into it in the meantime.


#8

no, i’ve only ever had one account and haven’t worked the repositories in yet at all


#9

Hi there,

We do have multi-region master/slave fail-over, but the lag should really not be noticeable to humans (yet).
I suspect it’s more a matter of the client-side app not doing proper cache-invalidation.

Did you work in multiple tabs at the same time? we haven’t yet implemented inter-tab sync, and the workspaces list is actually cached inside the client app.

Thanks,
Matthijs


#10

i am not 100% sure of what you mean, but i definitely do have multiple projects open at once and multiple files within each project open along with them.

However, i don’t recall that being the case when my workspaces went missing…


#11

Had a workspace disappear from a premium account last night (multiple actually) - some have reappeared, some not… Cloud9 - this does not inspire confidence…


#12

I have also had a workspace disappear. Some help would be much appreciated @bradydowling

Thanks


#13

I’ve also just had all four of my work spaces disappear. I cleared cache, logged in and out and restarted my browser and it’s still empty. Hoping it comes back soon…