Warning: PATH set to RVM ruby but GEM_HOME and/or GEM_PATH not set


#1

Warning: PATH set to RVM ruby but GEM_HOME and/or GEM_PATH not set, see:
https://github.com/rvm/rvm/issues/3212

/usr/local/rvm/rubies/ruby-2.3.0/lib/ruby/2.3.0/rubygems/dependency.rb:319:in to_specs': Could not find 'railties' (>= 0.a) among 16 total gem(s) (Gem::LoadError) Checked in 'GEM_PATH=/home/ubuntu/.gem/ruby/2.3.0:/usr/local/rvm/rubies/ruby-2.3.0/lib/ruby/gems/2.3.0', executegem envfor more information from /usr/local/rvm/rubies/ruby-2.3.0/lib/ruby/2.3.0/rubygems/dependency.rb:328:into_spec’
from /usr/local/rvm/rubies/ruby-2.3.0/lib/ruby/2.3.0/rubygems/core_ext/kernel_gem.rb:65:in gem' from /usr/local/rvm/gems/ruby-2.3.0/bin/rails:22:in'
from /usr/local/rvm/gems/ruby-2.3.0/bin/ruby_executable_hooks:15:in eval' from /usr/local/rvm/gems/ruby-2.3.0/bin/ruby_executable_hooks:15:in

Process exited with code: 1


#2

It could be fixed by entering “rvm use ruby 2.3.0” in terminal.
Please try this.


#3

I tried that and it did work i am using cloud 9


#4

I tried this and it does not work.

Most of my vm’s don’t pose the problem. Just made a new one and it does have the problem: c9user: andycapiauocmw, vm: mtcquery


#5

try killall tmux to restart all terminals. RVM error when opening new terminal


#6

i did and it didn"t work therefore i deleted that workspace and created a new one, now it works

thanks


#7

Thanks :slight_smile:

Currently I cloned a working environment, got rid of the rails and
installed a new one. This comment is definately more simple.

Thanks for the notification. I really appreciate it.

Best regards,
Andy