Vue-CLI Server Run Error

workspace
nodejs
server

#1

I have a Github repo with a vue-cli webpack project that I am trying to get running on C9.

My problem is when I run “npm run dev” it takes me to a page that says “No application seems to be running here!”

The project is running at http://localhost:8080 and shows no errors.

What’s going on here and how can I fix this? I’ve tried the solution in the link below and I couldn’t get it working. For step 6 I couldn’t find the webpack.config.js file either without going into the node modules.

Thanks!


#2

I’m having the exact same issues :frowning: I hope someone can figure it out!


#3

I’m having the exact same issue - have used older versions of the vue-cli without issue, but now starting a new project and can’t seem to get it to display despite zero errors in the terminal.

I get this in console: -.c9users.io/ Failed to load resource: the server responded with a status of 503 (Service Unavailable)

In older versions of vue-cli there’s been a dev-server file in the build folder, which actually started the server (app.listen etc.) and was where I would add extra things, like api routes, login logic etc. (as OP mentioned, this seems like it’s in node-modules)

That last bit is probably more of a question for vue-cli, but we should still be able to run the unmodified template and see it at localhost I think.


#4

Alright I figured out how to get this working.

Replace the dev line under scripts to the package.json file. You may need to add --hot but that depends on your setup.

“dev”: “cross-env NODE_ENV=development webpack-dev-server --open --inline --host $IP --port $PORT --public $C9_HOSTNAME --config build/webpack.dev.conf.js”,

Run npm run dev.

Go to the URL provided in the terminal. For me it was http://localhost:8080. It will take you to something like project-name-yourC9Username.c9users.io:8080. Remove the port number from that URL and it should start working.

Note: The project is a webpack project. Not a webpack-simple.


#5

It already looks like you got this working, but for future reference, the issue was likely that the server was set to run on localhost:8080; our proxy does not pick up localhost. The correct setting is to run through IP address 0.0.0.0, which is also stored in the env variable $IP.


#6

hi…I followed you methods in vue-cli version.2 but it’s not working in vue-cli3.
There was an error that said “Invalid Host Header” in Chrome.
How to do solve this problem…

Pleas let me know that problem…

Thanks…


#7

@skyjich In case this is still relevant to you.

vue-cli 3 does not accept the --public flag when you run the vue-cli-service serve (or npm run serve). To let your script know where to connect to you have to specify it in the vue.config.js file

config = {
devServer: {
public: ‘YOUR HOSTNAME’ // e.g. ‘workspace-username.c9users.io
}
}

module.exports = config;

The Docs: https://cli.vuejs.org/guide/cli-service.html#using-the-binary


#8

Hi dude,

I fixed that creating vue.config.js file (if you don’t have) and put this code

module.exports = {
devServer: {
disableHostCheck: true
}
}

Save, run npm serve again and enjoy it!