Vim mode isn't working

workspace

#1

Hi All,

I can’t exit insert mode while using vim without manually toggling the ‘Keyboard mode’. This is extremely frustrating! I hope this isn’t what I should expect of c9.io post amazon acquisition.


#2

Hi
An issue like this can happen if one of browser extensions consumes esc key before web pages can handle it.
E.g. vimium extension for chrome does this. The workaround is to disable vimium on c9.io.
If the above doesn’t solve the problem, could you please tell us more about the issue.

  • which browser/os do you use?
  • are there any errors in the browser console?

#3

Sorry about that, it was vimium haha. I installed in the other day and totally forgot about it.

Thank you @harutyun