Using HStore in PostgreSQL?

postgresql

#1

Hi all, I would like to ask if it is possible for me to install HStore to my PostgreSQL database?
I tried to get the plugin but failed due to the access right issues, anyone knows if it can be solved?


#2

Did you try with sudo? what error exactly did it show?


#3

Hi there, i am recently having the same problem, this is the error i got when i like to use hstore.

CREATE EXTENSION IF NOT EXISTS hstore;
ERROR: could not open extension control file “/usr/share/postgresql/9.3/extension/hstore.control”: No such file or directory

I have tried to install the contrib extension to use hstore withthe following command,
sudo apt-get install postgresql-contrib

and get this error,

sudo apt-get install postgresql-contrib
Reading package lists… Done
Building dependency tree
Reading state information… Done
E: Unable to locate package postgresql-contrib

If you can help e to solve this problem i will be glad.

Thanks,
C


#4

Can you try running sudo apt-get update before you install?


#5

Thank you. “apt-get update” works now.

At the time I used Cloud9 I don’t think my account has sufficient right to run “apt-get update”.

Regards,
Adam


#6

Thanks a lot updating postgresql solved my problem as well.