Upgrade RVM Error

ruby

#1

When using RVM, I get the the following warning:

Warning, new version of rvm available ‘1.29.3’, you are using older version ‘1.29.2’.

When I run ‘rvm get stable’ I get the following (urls removed because I couldn’t save):

Downloading get.rvm.io
No GPG software exists to validate rvm-installer, skipping.
Downloading rvm/rvm/archive/1.29.3.tar.gz
Downloading rvm/rvm/releases/download/1.29.3/1.29.3.tar.gz.asc
gpg: Signature made Sun 10 Sep 2017 08:59:21 PM UTC using RSA key ID BF04FF17
gpg: Good signature from "Michal Papis (RVM signing) <>"
gpg: aka "Michal Papis <>"
gpg: aka "[jpeg image of size 5015]"
gpg: WARNING: This key is not certified with a trusted signature!
gpg: There is no indication that the signature belongs to the owner.
Primary key fingerprint: 409B 6B17 96C2 7546 2A17 0311 3804 BB82 D39D C0E3
Subkey fingerprint: 62C9 E5F4 DA30 0D94 AC36 166B E206 C29F BF04 FF17
GPG verified '/usr/local/rvm/archives/rvm-1.29.3.tgz’
tar: .github: Cannot utime: Operation not permitted
tar: Exiting with failure status due to previous errors
Could not extract RVM sources.
Downloading mpapis/rvm/get/1.29.3.tar.gz
Downloading mpapis/rvm/downloads/1.29.3.tar.gz.asc
gpg: Signature made Sun 10 Sep 2017 08:59:29 PM UTC using RSA key ID BF04FF17
gpg: Good signature from "Michal Papis (RVM signing) <>"
gpg: aka "Michal Papis <>"
gpg: aka "[jpeg image of size 5015]"
gpg: WARNING: This key is not certified with a trusted signature!
gpg: There is no indication that the signature belongs to the owner.
Primary key fingerprint: 409B 6B17 96C2 7546 2A17 0311 3804 BB82 D39D C0E3
Subkey fingerprint: 62C9 E5F4 DA30 0D94 AC36 166B E206 C29F BF04 FF17
GPG verified '/usr/local/rvm/archives/rvm-1.29.3.tgz’
tar: .github: Cannot utime: Operation not permitted
tar: Exiting with failure status due to previous errors
Could not extract RVM sources.
Could not update RVM, get some help at #rvm IRC channel at freenode servers.


#2

Also, whenever I install a new ruby and run ‘rvm use’ for it, I get the following error:

bash: /usr/local/rvm/rubies/ruby-2.5.0/bin/gem: /home/travis/.rvm/rubies/ruby-2.5.0/bin/ruby: bad interpreter: No such file or directory


#3

It’s a problem of ruby-2.5.0

check here.

https://github.com/rvm/rvm/issues/4291#issuecomment-362042414


#4

Same problem, nothing to do with ruby 2.5: only ruby 2.3 and 2.4 installed.

rvm get stable
Downloading https://get.rvm.io
No GPG software exists to validate rvm-installer, skipping.
Downloading https://github.com/rvm/rvm/archive/1.29.3.tar.gz
Downloading https://github.com/rvm/rvm/releases/download/1.29.3/1.29.3.tar.gz.asc
gpg: Signature made Sun 10 Sep 2017 08:59:21 PM UTC using RSA key ID BF04FF17
gpg: Good signature from “Michal Papis (RVM signing) mpapis@gmail.com
gpg: aka “Michal Papis michal.papis@toptal.com
gpg: aka “[jpeg image of size 5015]”
gpg: WARNING: This key is not certified with a trusted signature!
gpg: There is no indication that the signature belongs to the owner.
Primary key fingerprint: 409B 6B17 96C2 7546 2A17 0311 3804 BB82 D39D C0E3
Subkey fingerprint: 62C9 E5F4 DA30 0D94 AC36 166B E206 C29F BF04 FF17
GPG verified ‘/usr/local/rvm/archives/rvm-1.29.3.tgz’
tar: .github: Cannot utime: Operation not permitted
tar: Exiting with failure status due to previous errors
Could not extract RVM sources.
Downloading https://bitbucket.org/mpapis/rvm/get/1.29.3.tar.gz
Downloading https://bitbucket.org/mpapis/rvm/downloads/1.29.3.tar.gz.asc
gpg: Signature made Sun 10 Sep 2017 08:59:29 PM UTC using RSA key ID BF04FF17
gpg: Good signature from “Michal Papis (RVM signing) mpapis@gmail.com
gpg: aka “Michal Papis michal.papis@toptal.com
gpg: aka “[jpeg image of size 5015]”
gpg: WARNING: This key is not certified with a trusted signature!
gpg: There is no indication that the signature belongs to the owner.
Primary key fingerprint: 409B 6B17 96C2 7546 2A17 0311 3804 BB82 D39D C0E3
Subkey fingerprint: 62C9 E5F4 DA30 0D94 AC36 166B E206 C29F BF04 FF17
GPG verified ‘/usr/local/rvm/archives/rvm-1.29.3.tgz’
tar: .github: Cannot utime: Operation not permitted
tar: Exiting with failure status due to previous errors
Could not extract RVM sources.
Could not update RVM, get some help at #rvm IRC channel at freenode servers.

Anyone have a solution??


#5

sudo rvm get stable

It works in my environment.