Upgrade Postgresql 9.6 - 10.0

postgresql

#1

Hello, is it possible somehow to update Postgresql to version 10?
I would like to use pgAdmin web application, but it requires PostgreSQL v10 which I can not install because of the error:

The following packages have unmet dependencies:
postgresql-10 : Depends: libicu52 (>= 52~m1-1~) but it is not installable


#2

I think I found detailed solution here