Unknown error: EIO: i/o error, open


#1

I ran into a “disk quota full” issue in one of my workspaces, and I deleted some things, and now I’m getting the Unknown error: EIO: i/o error, open error when trying to access some files .

It showed almost no disk usage, and when I just added another folder and one html file, I’m not getting the “Disk Quota Reached” message again.

dphayes/lt2501_codelab

I’d love to get access to the files again; if you can fix this workspace, copy to a new one, zip the files and send, etc.

Thanks.


#2

Can you try cloning the workspace to another one, and see if that has the problem too?


#3

I tried cloning it but get a **Creating workspace failed! ** message when I try to open the clone.

dphayes/lt2501_codelab-cloned


#4

And now, in trying to open the original one ( dphayes/lt2501_codelab ), I’m getting an “Archiving your workspace” message.

I don’t understand why it thinks this workspace is so large; it’s just a small number of text files and a few images.

In the forums, I’ve read some things about processes “stuck” running filling up tmp, but I’m not able to see what those are to stop them.


#5

It looks like there was some disk corruption in your workspace which is probably what caused it to report as full even though it wasn’t. I’ve fixed this now using fsck and we’ll investigate why the corruption occurred. Please let us know if anything is missing and we can restore your files from a recent backup if anything isn’t correct.

Regards, Tim


#6

If you can restore (or send) a backup from 12/2, that would be great.

Thanks.