Unable to start the server


#1

I have been using the system for over a year now and I am having a completely new issue when trying to start the server. Update: It seems the gem axlsx is causing it (I can start the server with this commented out of the gemfile) I still do not know why though and need help, please

The command I am using (and have always used) is " rails server -b $IP -p $PORT". The error I get is as follows:
bin/rails:6: warning: already initialized constant APP_PATH
/home/ubuntu/workspace/horsestud_app/bin/rails:6: warning: previous definition of APP_PATH was here
Error: Command ‘-b’ not recognized
Usage: rails COMMAND [ARGS]

In case the server wasn’t completely shut down I tried the command “fuser -n tcp 8080” so that I could use the “kill” command, but get the message
Cannot stat file /proc/11713/fd/10: Stale file handle

Can someone please help?

Thanking you in advance,


#2

You could try restarting your workspace entirely, and trying again and see if you still get the error.


#3

Thanks for the suggestion, but I did do this - several times, but it does not help. This has something to do with the axlsx gem since I can start it with this gem commented out, I want the gem so need to figure this out. Thanks.


#4

From the gem documentation, it seems you should take a look at this if you are using Rails.


#5

Yes, you are right. I had all three gems in my gemfile:
#gem ‘axlsx’
#gem ‘axlsx_rails’
#gem ‘acts_as_xlsx’

Acts_as_xlsx requires axlsx_rails which requires axlsx. So I was working my way down them to see which caused the server start-up issue and it failed with the first - axlsx.


#6

I just read my last response and it reads as if I have resolved the issue, which I have not. I cannot restart the server with these gems in the gemfile. Any help would be appreciated.