Unable to save in my workspace


#1

Hi guys, I’m unable to save in my workspace.


#2

It looks like the hane-demos folder is owned by the root user. Did you create it using sudo?

You need to set its owner back to ubuntu, you can do that with:

sudo chown ubuntu. hane-demos


#3

dont work mate
sudo chown ubuntu. hane-demos


#4

Ah sorry need the -R flag to make it set permissions for all files inside the folder too:

sudo chown -R ubuntu. hane-demos


#5

ninjoan:~/workspace/hane-demos $ sudo chown -r ubuntu. hane-demos
chown: invalid option – 'r’
Try ‘chown --help’ for more information.