Unable to publish C9 package


#1

Hello,

I cannot publish a c9 package. If I try to I get this error message

kallobernat:~/.c9/plugins/cie.eslint (master) $ c9 publish --verbose
Permissions are:  undefined
Data is:  {
    "name": "cie.eslint",
    "description": "An eslint plugin for Cloud9 which runs an external eslint.",
    "version": "0.0.0",
    "author": "cie",
    "contributors": [],
    "repository": {
        "type": "git",
        "url": "http://github.com/cie/cie.eslint"
    },
    "engines": {"c9": ">=3.0.0"},
    "plugins": {
        "eslint": {}
    },
    "categories": [
        "core"
    ],
    "licenses": [
        "MIT"
    ]
}

Permissions are:  world
WARNING: Description property in package.json will be ignored. README.md will be used.
Processing 2 files.
Compressing:  false
./
./__installed__.js
./package.json
./README.md
./worker/
./worker/eslint_worker.js
./eslint_test.js
Built package cie.eslint@0.0.0
Uploading package cie.eslint
Package not registered, creating new.
ERROR: Failed to upload new package to API - {
    "code": 403,
    "hostname": "newclient-gce-eu-106-prod",
    "scope": "api",
    "message": "Feature disabled"
}

What is the problem?

If it’s not possible to publish now, is there any way to run my plugin in non-debug mode?

Thanks!!


#3

Have you tried adding "permissions": "world" to your json?


#4

Thanks. Now I tried, but it does not work.

Permissions are:  world
Data is:  {
    "name": "cie.eslint",
    "description": "An eslint plugin for Cloud9 which runs an external eslint.",
    "version": "0.0.0",
    "author": "cie",
    "contributors": [],
    "permissions": "world",
    "repository": {
        "type": "git",
        "url": "http://github.com/cie/cie.eslint"
    },
    "engines": {"c9": ">=3.0.0"},
    "plugins": {
        "eslint": {}
    },
    "categories": [
        "core"
    ],
    "licenses": [
        "MIT"
    ]
}

Permissions are:  world
WARNING: Description property in package.json will be ignored. README.md will be used.
Processing 2 files.
Compressing:  false
./
./package.json
./__installed__.js
./examples/
./examples/.eslintrc
./eslint_test.js
./README.md
./worker/
./worker/eslint_worker.js
Built package cie.eslint@0.0.0
Uploading package cie.eslint
Package not registered, creating new.
ERROR: Failed to upload new package to API - {
    "code": 403,
    "hostname": "newclient-gce-eu-119-prod",
    "scope": "api",
    "message": "Feature disabled"
}

#5

sorry, publishing seems to be broken atm., we’ll try to fix it ASAP


#6

Do you have any progress? Thanks.


#8

+1 Publishing seems to be broken?


#9

Sorry for the delay here, a fix is in a pull request, and will be deployed in the next few days.


#10

looking forward as I’m getting the same error when trying to publish: https://github.com/Cloud9Linter/c9.linter.clang


#11

So…“Next few days should be interpreted as…???”.


#12

:disappointed: At this time we are still reviewing a fix for this. Unfortunately this will take a bit more time. Currently the only way is to manually publish and install with the approach described in the README of https://github.com/Cloud9Linter/c9.linter.clang.


#13

OK thanks for the update.


#14

Is there currently any way to publish packages that can be installed and used without being in development mode?


#15

Any ETA on the fix? Basically all custom plugins are not useable at the moment…


#16

Any updates on this issue?


#17

I’d like to update my plugins for c9. Any update on this issue? (PS I haven’t tried publishing again yet)…


#18

so same goes for me
"ERROR: Failed to upload new package to API - Feature disabled"

any update ??


#19

@harutyun

How are you doing? I i´m new to this, still getting this error, trying to publish my first plugin…


Can't install scala ide plugin
#20

Sorry for a very long delay. The new instructions for publishing and installing plugins can be found here Distributing and installing custom Cloud9 plugins. Please try, and let us know what do you think.