Unable to install WakaTime


#1

Hello everyone.

I am trying to get WakaTime installed on my workspace, and haven’t had any luck so far. Here is the exact steps I have followed:

Following instructions on https://wakatime.com/help/plugins/cloud9 I did:

  • Enable all 3 ticks on the configs screen
  • Got a new terminal open
  • Typed in c9 install wakatime

However, at this point instead of asking for my API Key as it should, it was asking for my c9 credentials. I typed in my username and password a few times, but it didn’t work.

After that, I tried loogging into the c9 website to check my password. It failed as well, saying that I had too many failed atempts.

I logged in using my GitHub as I always do and went to the password section of c9 to see if I even had one set. I set a new password just in case.

Two hours later, after the “too many atempts” thing was over, I was able to normally log in using username/password.

At this time, I tried installing wakatime again. I got this message:

WARNING: Directory not empty: /home/ubuntu/.c9/plugins/wakatime. Use --force to overwrite.

So, I did try with the --force arg, and this is what I got:

Unknown Error getting api.c9.io/packages/wakatime/versions/3.0.2/download?access_token=9c17PAHnvS3QtPQSUN8l:500   

The same happens if I try with sudo as well.

Can someone help me with this? Is this some kind of block on my account because of the password thing?

Thanks in advance!

Have a great day.


#2

This is an existing issue with plugin installs of any type. I’m not aware of an ETA for the fix but this will be updated when it is fixed.


#3

Is there no workaround we can implement in the meantime?


#4

Only walk around I know of is to find the source and manually install.

https://github.com/wakatime/c9-wakatime is the source


#5

By manual install, do you mean copying the source to ~/.c9/plugins and running the workspace in Debug Mode?

Because yeah, it works, but not really a solution to work on. I was hoping there was a better way :angel:


#7

@tuxmachine can you expand on how you did this please?


#8

Ok, so this is what I have done so far

$ git clone https://github.com/wakatime/c9-wakatime
$ cd ~
$ cd .c9/plugins/wakatime
$ cp -a ~/workspace/c9-wakatime/. ~/.c9/plugins/wakatime/

ls should show the repo where it should be

Then I used:

$ c9 run wakatime

Then get this output:

Permissions are:  world
Data is:  {
  "name": "wakatime",
  "description": "Metrics, insights, and time tracking automatically generated from your programming activity.",
  "version": "3.0.2",
  "author": "WakaTime",
  "contributors": [
    {
      "name": "Alan Hamlett",
      "email": "alan@wakatime.com"
    }
  ],
  "repository": {
    "type": "git",
    "url": "http://github.com/wakatime/c9-wakatime.git"
  },
  "plugins": {
    "wakatime": {
      "packagePath": "plugins/wakatime/wakatime"
    }
  },
  "engines": {
    "c9": ">=3.0.0"
  },
  "categories": [
    "miscellaneous"
  ],
  "license": "BSD-3-Clause",
  "licenses": [
    {
      "type": "BSD",
      "url": "https://github.com/wakatime/c9-wakatime/blob/master/LICENSE"
    }
  ],
  "installer": "install.js",
  "permissions": "world"
}
Permissions are:  world
WARNING: Description property in package.json will be ignored. README.md will be used.
Processing 3 files.
Compressing:  false
Done!

What next??

Don’t know where to put my API key

Halp


#9

So, go to Tools>Developer>Start in Debug Mode then you are prompted to enter your wakatime API key

Super fiddly

Is that how everyone else has done it?


#10

Any idea when this is gonna be fixed ?


#11

I’m not aware of an ETA for the fix but this will be updated when it is fixed.


#12

I am having the same issues, but cannot install even in debug mode or manually, like suggested above. This is the error:

Unknown Error getting api.c9.io/packages/wakatime/versions/3.0.2/download?access_token=***************:403

Seems its not allowed to download what it needs.

Is this an issue with my username and password?

Is this going to be fixed?


#13

OK finally got it working … just used this https://wakatime.com/help/plugins/cloud9
Don’t use the c9 CLI