Unable to access preview site for testing my rails for ruby website


#1

Whenever I try to visit my preview site ("[application_name]-[my_username].c9users.io"), I get the timeout error as shown in picture below:

I successfully used the preview site earlier, but suddenly it stopped working. This happens regardless of whether I run webrick server or not. I am trying to run tutorial site detailed in https://www.railstutorial.org/book/sign_up


Rails server stops loading after first successful run
#2

Hey @atifhans,

C9 often needs a few special settings to run various servers. Have you looked over the Ruby on Rails C9 docs yet?

:books: :snail:


#3

Yes, I have looked at the docs, they don’t provide any info to help my situation. In fact, the docs have to be updated as all user generated content will be at “http://<workspacename>-<username>.c9users.io” instead of “http://<workspacename>-<username>.c9.io”. I think that it is not a server problem as I was able to visit the preview page before even if no server was running. It used to give page not found error.


#4

I’m having the exact same issue …and on three separate workspaces. It worked once, now it’s not working at all …even after trying the steps at https://docs.c9.io/docs/running-a-rails-app.

Are others having this issue?

And is there a workaround of some kind?
I’d really like to continue using c9…


#5

My issue got resolved on its own, took a couple of days. I think it was a problem from their side. These kinds of issues really make me rethink about putting my work on the cloud. Configure your workspace locally also as a backup.