Unable to access google app engine api explorer


#1

Hello, I just installed the appengine SDK for python and launched a small project. Everything works fine, except the access to the api explorer.
This is probably due to the fact that the dev_appserver.py is not supporting https.
I could workaround for the app itself to run it in a new tab with http:// but for the api explorer with
…/_ah/api/explorer this technique fails.
The only solution I could think of is to install ngrok and proxy the dev_appserver.py over https.

Does anyone has experience with this and what would be the configuration for such a reverse proxy?
Can someone think of an easier solution?

Thank you.


#2

I had a partial success. I am still not able to access the api explorer but at least I got the api endpoints working.

The problem was the the api returned $IP:$PORT as address which is 0.0.0.0:8080.
Of course there is no dns resolution for this address :wink:

The workaround is to include the hostname parameter when creating your api as documented here:

https://cloud.google.com/appengine/docs/python/endpoints/create_api

I used hostname=os.getenv('C9_HOSTNAME) + ‘:’ + os.getenv(‘PORT’)
which worked fine.

If someone manages to gets the api explorer working at http:/$C9_HOSTNAME/_ah/api/explorer please let me know.