Typescript version outdated


#1

$ tsc --version
Version 0.9.7.0


#2

We’ll update shared typescript to 1.8.0. Thanks for reporting!

Note that you also can install any other version with npm i -g ... too.


#3

Thanks! I did try to install the libraries globally, however even with sudo I was not able to update the linked shared file at /mnt/shared/bin/tsc (/mnt/shared (something) / tsc) which was a sym link. I was unable to update the sym link, or the tsc binary it was linked to. I npm installed typescript locally, tried ./node_modules/typescript/bin/tsc to compile my code, for whatever reason it flopped every way to sunday on the compile. This issue was on the Custom workspace. the HTML5 work space had at least tsc 1.7.x which worked as expected.
Thanks for getting back to me so quickly!


#4

/mnt/shared/ is readonly, but it is in the end of PATH, so if you run npm install -g typescript tsc from it should come first


#5

Hi,

I keep having difficult time to work with Cloud 9 IDE due to different packages being outdated. Trying to update any software seems to be a hassle as well. I hope cloud 9 does something about this. For example: TypeScript again is being outdated. We are in version 2.0 + and things are failing. npm install -g typescript@next does not work either (or npm install -g typescript) it keeps using the old one which is 1.8.

Thank you for providing the Cloud 9 workspace.

Thanks