TMUX backgrounding/switching sessions only works one time


#1

I’m running into something weird with TMUX where I can detach a session to have it go into the background and keep running (Ctrl + b; d). This works fine. But then if I right click in a terminal window and locate my session and switch back to it, I cannot detach it anymore after that so that I would have to kill the process, close the terminal, open a new terminal, start the process again, then detach this new window to have the running process backgrounded again. This is, obviously, less than ideal. Any ideas what’s going on?


#2

I’m not sure exactly what’s happening here, but it might have to do with how terminals work on Cloud9. In the background, terminals are generated using tmux, and then displayed inside the terminal area. The problem you’re experiencing might have to do with you running tmux inside tmux, which is not recommended. You’ll be better off just arranging the windows to form the arrangement you want (unfortunately, that won’t help with shortcuts, but you might be able to customize shortcuts to be like tmux in the workspace Preferences.