This exact program works on my school laptop, but won't work on my mac


#1

So when I was working on my text rpg that I have been making to practice my coding, (C++), it worked perfectly on my chromebook, but when ran on my mac it has these errors,


I was wondering if this has to do with the operating system or if these errors are problems with my code but, as I have said before, it worked perfectly on my chromebook.
Please leave any solutions or if a worker at c9 sees this, please fix this issue. :slight_smile:
Thanks!


#2

First of all, this is the wrong board. You are not experiencing a c9, you are having an issue with your own code.

I cannot point out the issue from a small fragment of code, but it smells like you are not matching parentheses somewhere.


#3

No, this works when I run it on my chrome book, this is only when I run it on mac.


#4

Look at the first error in your picture, it says in function void textRpg(). The issue starts there, not in main, perhaps look at it more carefully.


#5

found the problem, thanks!