The server keeps crashing giving fatal SignalException

ruby

#1

The Ruby programs i write do not run. They were running perfectly fine until google chrome crashed. I restarted everything and now the console keeps giving the following error message

[2016-02-12 15:58:33] FATAL SignalException: SIGTERM
        /usr/local/rvm/rubies/ruby-2.3.0/lib/ruby/2.3.0/webrick/server.rb:177:in `select'
        /usr/local/rvm/rubies/ruby-2.3.0/lib/ruby/2.3.0/webrick/server.rb:177:in `block in start'
        /usr/local/rvm/rubies/ruby-2.3.0/lib/ruby/2.3.0/webrick/server.rb:33:in `start'
        /usr/local/rvm/rubies/ruby-2.3.0/lib/ruby/2.3.0/webrick/server.rb:164:in `start'
        /usr/local/rvm/gems/ruby-2.3.0/gems/rack-1.6.4/lib/rack/handler/webrick.rb:34:in `run'
        /usr/local/rvm/gems/ruby-2.3.0/gems/rack-1.6.4/lib/rack/server.rb:286:in `start'
        /usr/local/rvm/gems/ruby-2.3.0/gems/railties-4.2.5/lib/rails/commands/server.rb:80:in `start'
        /usr/local/rvm/gems/ruby-2.3.0/gems/railties-4.2.5/lib/rails/commands/commands_tasks.rb:80:in `block in server'
        /usr/local/rvm/gems/ruby-2.3.0/gems/railties-4.2.5/lib/rails/commands/commands_tasks.rb:75:in `server'
        /usr/local/rvm/gems/ruby-2.3.0/gems/railties-4.2.5/lib/rails/commands/commands_tasks.rb:39:in `run_command!'
        /usr/local/rvm/gems/ruby-2.3.0/gems/railties-4.2.5/lib/rails/commands.rb:17:in `<top (required)>'
        /home/ubuntu/workspace/bin/rails:9:in `require'

#2

Hey @Rishit_Shah :slightly_smiling:,

Sorry to hear that, are you still having issues? If so, if your project is public, may you share the link to the workspace and we’ll take a look. :hand::smiley:

Also might be good to double check Brady’s article here on Rails in C9:

and I found this article online that goes into every step of setting up a Rails Cloud 9 IDE Workspace:

Best,
Mike
:alien: