Terminals are unresponsive


#1

Hi guys,

I’ve been learning how to use React and started up a workspace in c9 to play with things. It is located here. I’ve been having some issues with the workspace itself and would love some help.

For the past day and a half, I’ve been having issues in which my terminals don’t want to load up. I’ve attached an image below. The terminal will just sit there with a small spinning wheel without ever doing anything. I’ve tried opening and closing the terminals, restarting the workspace, and clearing browser data from c9.io. Nothing has helped. Yesterday, the terminals would load up eventually, but for about 10 minutes after they had successfully loaded, keystrokes would be delayed dramatically. I would type and the text would be entered ~1-2 minutes later. Today, they refuse to load at all. I don’t really know what could be going on.

Interestingly, the c9 editor is working fine, but it seems to have trouble saving the file once I’ve edited it. One other thing to note is that every 10 seconds, a “Reconnecting” box pops up in the upper right and then immediately disappears. If there’s any other info that would help, just let me know.

Thank you for your time and help!

Cheers,

Jaydon Carling


#2

Just an update, this is happening in all my workspaces. I created a brand new one today, and I’m still getting issues with not being able to use the terminal at all. I’m on a student plan, so I can’t contact support. At this point, Cloud9 is basically useless to me. I’m supposed to do my coding homework with it, but I’ll just have to make different arrangements with my professors. If anyone has any ideas, please let me know.

Cheers,

Jaydon Carling


#3

Sounds like your network connection may be slow / intermittent. Are you getting wireless disconnects?


#4

I don’t believe that is the problem. The issue persists over three different network connections. I spend most of my time on campus, and I’ve tested both a hardline and wifi connection into the University network. I’ve never had an issue with speed on this network. It averages ~100 Mbps up and down, and my connection is consistent. I’ve also tried the personal hotspot on my phone which is slower, but still very useable over LTE. The terminal has issues on all of the connections that I’ve tried.


#5

What browser are you using?


#6

I’ve tested it in both Safari 10.1 and Chrome 57.0.2987.133 running on MacOS 10.11.6 (15G1217)


#7

Just for reference, have you tried using Cloud9 through Tor?


#8

No, I’ve never tried that.


#9

Huh. Well, I just tested it again in Chrome, and it seems to be working, but it certainly was not working yesterday. I guess I’ll get to work and hope for the best.


#10

I would try it. Comcast blocked Cloud9 for no good reason very recently (Can't access c9.io (Comcast)). Using Tor would help you figure out if your ISP is up to no good.


#11

I’ll give it a shot. Thank you!