[sudo] password for ubuntu:


#1

Where can I find this the password?
Thank you!


#2

It doesn’t have password by default


#3

v_ladimir:~/workspace (master) virtualenv venv Using base prefix '/usr' New python executable in /home/ubuntu/workspace/venv/bin/python3 Not overwriting existing python script /home/ubuntu/workspace/venv/bin/python (you must use /home/ubuntu/workspace/venv/bin/python3) Installing setuptools, pip, wheel...done. v_ladimir:~/workspace (master) source venv/bin/activate
(venv) v_ladimir:~/workspace (master) $ sudo -i -u postgres
[sudo] password for ubuntu:


#4

on which workspace do you see this?


#5

That is odd, because there should not be a password for sudo. The password should be ubuntu. If it isn’t, it may be your account password. I know another possible solution if these don’t work. Tell me if it requests a password when you run sudo su -.


#6

my workspace is urfin_bot


#7

There is no sudo password unless you set one. Just press enter on the prompt.


#8

OK, I just figured it out. I tried this, and I got the same result. Run this instead:
v_ladimir:~/workspace $ sudo su -
root@v_ladimir-urfin_bot-XXXXXXX# virtualenv venv
root@v_ladimir-urfin_bot-XXXXXXX# source venv/bin/activate
(venv) root@v_ladimir-urfin_bot-XXXXXXX# sudo -i -u postgres

Then, you will not be asked for any passwords, and the result would be the same. This worked perfectly for me.
In a nutshell…
SOLUTION: You need to be the root user for this to work.


#9

Thank you!
It’s OK!)


#10

Glad to hear it worked!


#11

This solution does not work for me.
marekzp:~/workspace $ sudo su - prompts a [sudo] password for ubuntu: and not “ubuntu”, nor blank, nor my user password works.
What am I doing wrong?