`sudo apt-get update` isn't working on blank workspace

workspace

#1

I’m trying to install a package that requires me to update the apt sources.lst. Every time I run sudo apt-get update I get an error saying The method driver /usr/lib/apt/methods/https could not be found..

E: The method driver /usr/lib/apt/methods/https could not be found.
N: Is the package apt-transport-https installed?```

When I try to install `apt-transport-https` it informs me that it can't locate it.
```me:~/workspace $ sudo apt-get install apt-transport-https
Reading package lists... Done
Building dependency tree       
Reading state information... Done
E: Unable to locate package apt-transport-https```

Could someone help me find a solution to this? I can't imagine that I'm the only person that needs to install packages this way.

#2

You aren’t. I am having the same problem. Did you ever find a solution @Jon_Green?


#3

In fact, I did find a solution. You need to install apt-transport-https before adding any https repos to your /etc/apt/sources.list.

sudo apt-get install apt-transport-https

I’ve asked c9 support to have this installed on all workspaces by default.

I’ve made an internal note for us to get apt-transport-https added to workspaces by default but I don’t have any sort of timeline or estimate on that. - Brady

Hopefully, they get this in soon so people like us don’t have to waste time scratching our heads. That said, c9 still is quite amazing and I love using it!

I hope this helps!!


#4

This should be fixed. I can’t find that previous conversation but I did make that change and rebuilt all the workspaces. I just made a new workspace now and apt-get update is working as expected, and there are checks in place now to make sure it doesn’t happen again.

Are you still having this issue with new workspaces?


#5

Hi, I’m sorry to be jumping in this thread, but I am experiencing the same issue, with a newly created blank workspace. “Apt-get update” tells me that apt-transport-https isn’t found, and then when I try to install apt-transport-https, it cannot locate the package. Could you help me with this?


#6

To solve this, look for any URLs with HTTPS in files in /etc/sources.list.d, and either change them to HTTP or rename them temporarily. Then, run sudo apt-get update and sudo apt-get install apt-transport-https. After that, revert the changes made in /etc/sources.list.d, run sudo alt-get update and now everything should work.


#7

Hey,

Sorry for the slow response, I was on holidays. If you’re still having issues with this, please let me know the workspace you’re having issues with and I can investigate. I can’t replicate this issue with a new workspace at this time


#8

Thank you, I managed to solve this successfully, it was a mistake on my part :slight_smile:


#9

Justin, does the offer to look at a workspace still stand? I’ve tried solutions from a dozen different forum threads.