Stable eslint version / selection of version


#1

Hi Guys,

The eslint support in CLoud9 seems to have been changed. I modified my .eslintrc, in the past, to reflect the version used inside cloud9. I suggested back then that you should add the option of selecting a version of eslint for the user. Right now it seems like you updated the eslint version, and my .eslintrc is not compatible any more. This really is a pain in the ass… I have a team of developers working on cloud9, and if you change stuff like that behind our backs, it’s very annoying. Can you please provide stable support for eslint, and preferably the option to select what eslint version should be used ?

Thank you for your response !


#2

The default linter in Cloud9 IDE uses a browser copy of eslint that does not support all of the same features as the cli tool, I wrote this plugin to fix the issues I had been having personally and it supports eslint properly like if you were using the eslint cli, because of this is it should remain stable and is also possible to install the version of eslint you specifically want to use if needed.