SSH workspace can't load directories


#1

I just created a new SSH workspace which connects to a directory on a rPi running raspbian. It seems like the workspace was created successfully but when I enter the web IDE for the workspace the directory tree in the left pannel just keeps loading endlessly. It looks like this: http://imgur.com/KY5eeOr

I’ve been waiting for probably at least 30 minutes but nothing happens.Earlier I have successfully created SSH workspaces for other machines and I’ve never stumbled upon an issue like this one. I would appreciate any advice I can get. The user used for accessing the workspace directory should also have full rights for the dir and files so I don’t think that should be the issue. I also have no issues with connecting to the machine over SSH from Putty.


#2

This can happen if cloud9 can not connect to the vm.
Can you try opening settings page of ssh workspace https://c9.io/<username>/<workspace-name>/settings and clicking save button, to see if there are any errors with the configuration


#3

When I’m doing that it says “timeout” after a while. Which is very strange. Because I can connect to my machine from any other location. I tried using a VPS of mine to connect to it through ssh and there were no issues at all. And when I created the workspace it successfully connected to it and created the .c9 folder etc. The same happened when I tried recreating it. So it’s able to connect and add the .c9 folder + files to the machine but then it stops working.

Worth mentioning might be that when I go to https://c9.io/<username>/<workspace-name> and click on the “files” tab it’s sometimes able to load and display the local files of my remote ssh workspace. So it should be able to connect to it. :S

EDIT: When I now tried to recreate the workspace again (I removed the .c9 folder and removed the workspace from my c9 account) I got the same problem. But when I now go to the settings page and try saving my settings it’s telling me that it’s able to update the settings successfully and I’m not receiving any timeout error. And as I mentioned earlier it’s able to read the files for the “files” tab. It’s just that it’s never able to actually load the workspace in the IDE.