SSH workspace - Bug on the search in folder

ssh

#1

Hi,

I have an SSH workspace with different project on it.

Recently, the search in folder don’t work at all. I have this screen : http://goo.gl/8WvFPc

I see a limit in the configuration : “searchLimit”. What is exactly this limit?

Thx for your answer.


#2

Hi,

searchLimit is the maximum number of files loaded into navigate panel

The error above may happen if there are too many files in the folder, and nak takes too long to process them.
Try searching in a smaller folder. If that works, you can configure folders that should be excluded from search with ignore pattern in project settings

If that doesn’t help nak intallation in ~/.c9 might be broken try

cd ~/.c9
rm -rf node_modules/nak
npm i https://github.com/c9/nak/tarball/c9

will fix it.


#3

I try to search in a smaller folder (just 5 files in the folder) and it didn’t work.

I try the command line for installation of nak but no change :sleepy:

An idea?


#4

try adding console.log calls to https://github.com/cloud9ide/nak/blob/master/lib/nak.js#L27 in ~/.c9/node_modules/nak to see if it gets called at all, and check if there are any errors in browser console.


#5

This is the result of the console.log => http://snag.gy/xflpS.jpg


#6

Is that all of messages displayed in console? Screenshot seems to show only old requests from loading, which do not give new information, unfortunately. Could you clear all before searching, or copy paste full text.