Spring Boot Application not accessible


#1

Hi,

I have just deployed one Spring Boot application and it is started well. I can see the application initiated at 8081 post. But When I am checking the listening port list from “netstat -atun”, I could’t locate this port on which my app is running. Hence I am not able to access it from outside/inside.

Please help me resolve this issue. Let me know if more information is required.


#2

Hi,

Services started on 8081 can be accessed on that same port from the outside. e.g. https://projectname-username.c9users.io:8081/


#3

No I couldn’t access it from that url. I already tried it. I couldn’t even see 8081 port in listening port list.


#4

Hello, I have the same issue.
I tried also with running the app with sudo.
Ports I tried with 8081, 8082, 80


#5

Hello, so basically the issue was with Postman that I was using to access the route.
Here you find the answer:

Just make the app public when you want to use Postman.

Moreover, I ran Spring Boot on port 8080, however in order to access the app from the outer world you want to connect to:
https://workspacename-username.c9users.io/endpoint

Without 8080 in the URL

Cheers


#6

After restarting the workspace now it works just on 8082 just so you know.