Splitting panes and binding


#1

Hello

Having issues with windows + window panes and binding to ports and accessing application. I made a short video: https://db.tt/zOe8n0Wl

Hopefully someone can help me and guide me to the right direction :smile:

Thank you for your time!

Best regards,
Artem


#2

Hey Artem, let’s de-bananafy this for you:

  1. Split UI: That looks buggy. I tried doing exactly the same as you did in the video and could not reproduce the issue. Can you check the Javascript console in your browser and paste any error message you might see? Any special settings you configured? If we can reproduce the bug we will fix it.
  2. Binding to Ports: Your local server needs to bind to 0.0.0.0:8080 or $IP:$PORT. Then you can access it via https://<workspacename>-<username>.c9users.io. Check the docs on how to run an application and bind to multiple ports.
  3. Port 80: Port 80 is privileged and your process needs to run as root to be allowed to bind to this port. In order to access your app via the proxy, you need to bind to ports 8080-8082 as explained above. These ports also don’t require root privileges.

Hope that helps, let me know what else we can do!


#3

Hello

Thank you for quick reply ^_^.

I will try and reproduce my steps here (using Opera, but same happens in Google Chrome):

  • Went to create new private workspace
  • Selected custom and screen hangs here.
  • Only way to proceed is to refresh the page
  • Went back to dashboard
  • Refreshed page (my workspace appeared)
  • Opened workspace
  • Fiddled with panes and got some issues
  • Tried disabling ghostrank + AdBlock
  • Panes started to work :slight_smile: (yay)

Got still this errors in console:

workspace-default.js:24262 [watchers] ignoring preview/ignoreState tab /README.md workspace-default.js:5140 [OT] Join /README.md workspace-default.js:5164 [OT] Joined /README.md workspace-default.js:16419 [language] Sent to worker (documentOpen): /README.md length: 18 workspace-default.js:16419 [language] Sent to worker (switchFile): /README.md length: 18 workspace-default.js:16419 [language] Sent to worker (switchFile): /test length: 1 workspace-default.js:19786 GET https://d6ff1xmuve0sx.cloudfront.net/nc-3.1.701-3f32f36c/static/plugins/c9.ide.layout.classic/images/running@2x.png 404 (Not Found) workspace-default.js:16419 [language] Sent to worker (switchFile): /README.md length: 18 workspace-default.js:16419 [language] Sent to worker (documentOpen): /README.md length: 18

Thank you for help with ports.

P.S. While u’re here maybe you can explain account limits when sharing. Example: I have 1 account and purchase paid plan (yay) and create 3 private workspaces. From these two I share with my colleague who is on free plan (needs more convincing). Will that work? Or will he need also a paid plan in order to have access to my 2 private workspaces? (hopefully that made sense).

Thank you again.

best regards,
Artem


#4

Excellent, welcome to Cloud9! :wink: You can share your workspace with your colleagues, even if they don’t have a premium account.

Solution in case somebody searches this post:

Looks like the Ghostrank or AdBlock extensions caused the issue and it was fixed by disabling them.

Happy coding!


#5

Thank you very much!