"Something went wrong" Runner/site error plus VM Info failure


#1

I logged into my workspace, and got a notice that it was migrating to a new server. No problem, it was a polite note with a progress bar, and I waited a bit and my workspace opened up.

After that, at least two problems occur:

(Edit(3): Briefly working, and then broken again, but see below for a workaround) First, the site can not be loaded at all on at the URL it is supposed to load at, including when using the default runners. I see:

Something went wrong !
Server timed out or sent incomplete response
Click here to try again. (Perhaps you meant to use HTTPS instead of HTTP?)
If that still doesn't work, please Issue a bug report.

Second, and possibly related, the VM is using zero memory, zero CPU, and zero disk. I have tried restarting and even resizing it, but it sits at zero:

This is my first problem with c9, and I’m on a deadline, so if there’s a better way to submit this, that information would also be helpful. Thank you!


#2

Oh, as a followup (and possibly totally unrelated), I had to create this forum account, and it let me use the same account name as that which my workspaces are under. If this forum is supposed to be connected to the main site and use the same account database, it is possible there’s a problem with my account. Just in case, my account username is evanedwards.


#3

The runners have started working again. The VM information is not yet displaying anything.

Perhaps it just takes some time after a migration for all interfaces to update?


#4

And it’s back to broken, no changes on my end. I tried restarting the VM.


#5

Woo! Found the Twitter support account. Seems that this old help fixes it. I’ll keep using it for awhile to verify, then mark that part as having a workaround. The VM stats still show “zero down the line.” Possibly related to yesterday’s server problems (earlier today for those of us in the US).

Cloud9 IDE Support ‏@C9Support Nov 19
Issues with the Apache runner. A fix will be live in the next day, but for now run Apache from the terminal with “apachectl start”

I’m learning where to go for help here. Nice interfaces, but quiet. So far no replies. :smile:


#6

HI Evan, right now pretty much everyone at C9 is on their way to Amsterdam so we are bound to business hours atm :slight_smile: Are you still having issues?


#7

At this point all the Runners (including the default ones) fail in that odd error message (proxy?), but I can manually launch Apache2. So it is really just the VM stats that are broken, which are not in any way required; I just worry that it’s a symptom of a problem that will escalate.

I can get work done for now, so I’m perfectly okay with waiting until after I finish this deadline and when somebody can assist. Thanks for the reply! :+1: