"Something went wrong!" - CodeIgniter

apache
codeigniter
php
mysql

#1

So I broke my git instance on one of my VM’s and could not fix it. So I deleted it and created a new instance and tried to load it up. But every time I try to view my site I get the following error.

Something went wrong !
Server timed out or sent incomplete response

Click here to try again. (Perhaps you meant to use HTTPS instead of HTTP?)

If that still doesn’t work, please Issue a bug report.

I have tried increasing the memory, I have tried restarting the server, and I have check the logs. I can find no reason why my server is giving this error.

Not sure what information you guys might need to help me, but I am stumped at this point.


#3

Can you let me know which workspace it is so I can take a look at it?


#4

The url for the workspace is: http://allrise-tgeene-1.c9users.io/

It seems to be working this morning, but the last two days it has been hit or miss if it is up and working.


#5

Alright, I’m watching this thread now so I’ll get notifications any time there are updates. Let me know if this happens again and I’ll jump right on it.


#6

The site is down again.


#7

Thanks for reporting. Let me look at it.


#8

I’m going to make the app public for a sec (not the code though) so just bear with me.


#9

Darn it, it looks like it’s good for me now. Is it still showing that error for you?


#10

Yes, I still have the error.


#11

Can you try clearing your browser cache? I’m able to see the app without any issues. I’m also looking into your Apache logs to see if there are any issues that that might be causing this.


#12

I think this is something I’m going to have to look further at on Monday but please clear your cache and try previewing the app in a different browser and that should work since it’s showing up for me. Let me know if you have any further details.

Thanks,
Brady


#13

I cleared my cache earlier today, and I think that might be why it was working. But I can’t go clearing my cache every 30 minutes just to keep developing, and I know my app isn’t using any browser caching directly.


#14

Ok, I think I have found a fix for the site. For some reason, the IDE doesn’t like working with CodeIgniter cookie based sessions. I noticed the system always bugged out when ever I tried to log into the system, so I switched to using a the CI database sessions and it seems to be working. Sorry for wasting your time. and thank you for trying to help.


#16

Interesting to know this because I’ve never seen this before. Thanks for mentioning this, hopefully it will be helpful for someone else in the future.


#17

TGeene is correct. I am also using codeIgniter and i keep seeing “something went wrong” message. But if i open the same URL from a different computer it works. When i clear cookies on my original computer then the URL starts working. Maybe i have to implement the same workaround suggested by TGeene.


#18

Thanks for confirming. I’ve also made an internal bug report about this so we can investigate this and address it.


#19

I am experiencing the same issue in my codeigniter project and I can confirm that the session cookie is not being stored in the Cloud9 environment. Apart from the database session workaround, is there any other way to overcome this issue?


#20

I haven’t been able to find another work around, but I will say this. The Database sessions kick me out about every 2 minutes and I have to re-login.


#21

I assume you are running into this problem http://forum.codeigniter.com/archive/index.php?thread-64427.html. The CodeIgniter application on the workspace is running behind a reverse proxy which causes REMOTE_ADDR to always be the IP of Cloud9’s proxy. The real IP of the user is in the X-FORWARDED-FOR header.
Could one of you try adding

$_SERVER['REMOTE_ADDR'] = $_SERVER['X-FORWARDED-FOR']; 

to the index.php and report if that fixes the issue?

Best,
Fabian


#22

So I just tried your fix, and I am still receiving the same error when I stop using Session Database Tables. I was really hopeful. If you find any other idea’s let me know and will try them out as soon as I can.