Solved! (was: I'm locked out of my workspace)


#1

Hello, I’m using a C workspace for my edX course. Haven’t accessed it for a while and now if I open it, this message pops up: 'You don’t currently have access to this workspace Would you like to request access?'
Also, the workspace is visible only in ‘shared with me’ and apparently has two members, me and another account with a very similar name to mine. What happened, can someone help? All my coursework is saved in this workspace :frowning:


#2

Oh my - it seems like the login interface of edX that is linked with C9 workspaces doesn’t work very well with C9’s own login page. I was able to restore my workspace using the edX login but it still won’t show up under the ‘workspaces’ tab within C9. I’m just happy to have regained access to my coursework, please consider this problem solved.
Thought I put this here for others who might encounter the same problem.


#3

It sounds like you have 2 separate accounts, one which is linked to your EDX account, and one other normal Cloud9 account. This is why you can’t access the workspace or see it in your dashboard when logged into your C9 account.Just make sure you log in through EDX in the future to access it. Or if your normal C9 account has nothing in it you could always delete it so you don’t get confused.