Soft tabs set, but hard tabs showing up


#1

I have soft tabs enabled, but not only is the editor putting actual tabs in instead of spaces, if I type [space][space], it converts it to a tab. I’ve read that the editor tries to read existing files to guess your settings (I have Autodetect turned off if that matters), so I tried with a new file. Here is the relevant section of my settings file (which I edited through the GUI):

"ace": {
    "@guessTabSize": false,
    "@newLineMode": "unix",
    "@tabSize": 2,
    "@useSoftTabs": true
},

When I turn off soft tabs, it stops converting spaces into tabs, but either way, when I hit enter at the end of a line, autoindent uses a tab instead of spaces.