Session not created exception: Chrome version must be... Small $ Bounty to solve


#1

I’m webscraping using Selenium with Chrome as the driver while using Ruby on Rails. My project was working fine, then one day I log in to run a web scraping task and get the error

session not created exception: Chrome version must be >= 64.0.3282.0 (Driver info: 
chromedriver=2.37.543610 
(afd36256570660b5a2f0e4dbd1b040f3dcfe9cb5),platform=Linux 
4.9.80-c9 x86_64)

My Gem File

gem 'webdrivers', '~> 3.2.4'
# IEDriverServer, MicrosoftWebDriver, chromedriver, geckodriver, phantomjs
gem 'watir'

Code Trying to Run

def mastersave
     require 'watir'
     @browser = Watir::Browser.new :chrome, headless: true
end

The gem ‘webdrivers’ downloads different drivers that allow me to use firefox, chrome, etc… with Selenium. I changed nothing when I logged in and suddenly started getting this error message when trying to use Chrome. I have never been able to get the other drivers to work but I’d be willing to use them if I could.

I’ve tried downgrading the gem ‘webdrivers’ all the way back to it’s first release and all in between, but that didn’t work. I also tried downgrading Watir to previous versions to be able to use phantomjs with it again since that’s what worked before and it’s now deprecated, but that didn’t work either.

I got 10 bucks through PayPal for anyone that can fix this or help me to. It was an incredible headache to get this all figured out in the first place.


#2

Update to latest headless chrome 65.0.3325.162


#3

Just a heads-up, we don’t allow Selenium/headless Chrome at this time on c9.io-hosted workspaces due to the strain that it can cause on other users. I’d recommend using either AWS Cloud9 (with dedicated EC2 instances) or an SSH Workspace/Environment, since both of these options will allow you to run these more hardware-intensive processes without affecting other users on shared hosts.


#4

Appreciate it, thanks.