Server times out when previewing project [SOLVED]

preview
runner

#1

My app is supposedly running according to the interface but I get no response from it when i try to load pages. According to the dashboard no cpu usage. The project is running php and mysql.

I have a school project due tomorrow that requires us to use c9. I’d greatly appreciate any help or information you could provide on how to get it working again.

EDIT: The server times out regardless of whether the project is running. There used to be a nicely formatted page stating that the project wasn’t running. I’ve tried everything I can think of to get this running. I’ve read through numerous posts of similar problems and found no solution. Has anyone had a similar issue?

EDIT2: Restarting from the resources menu on the right (mem, cpu, disk) fixed the issue. (as opposed to restarting cloud 9 entirely from the menu on the left)

Here is the preview page for the project - more details below.

I would add a screenshot of the project and resource usages but I’m a new user so no second image allowed =
Any way it reads:
Memory: 123MB / 2024MB
CPU: 0%
Disk 30MB / 512MB

Memory: 1GB Disk: 5GB

All of the processes read CPU: 0% and MEM: 0%

Thanks


#2

I received a message in the project view suggesting to kill the Apache processes and restart the work space. I tried this and it doesn’t seem to have worked. Also the sidebar with the message closed upon restarting the space and I’m unable to reopen it so I can’t very well respond through the project view (which is why I’m posting here).

Thanks for getting back to me.