SDK installation issue

sdk

#1

So I have a fresh install on ubuntu, and when starting up the server and going to the address we get the following error:

SyntaxError: Unexpected token u

this error comes as a popup.

On the server I can see it stops after hitting the cache for the default/dark.css skin.


#2

Chiming in to say I’m one of @shadowcodex shadowcodex’s developers and I tried to hit the same server while he was working on it. This error image is what popped up on my screen and now it pops up on his every time he visits the workspace.


#3

try enabling pause on all exceptions in chrome devtools, and reloading the page, it should show more comprehensible error message and stack.


#4

Here are the errors we are getting… Pasting them here for info. Then I’ll start reading into them.


#5

Running a reinstall after changing some npm settings. I have a feeling something was installed right.


#6

most likely an error while installing tern_defs https://github.com/c9/c9.ide.language.javascript.tern/blob/master/tern.js#L14


#7

I’m installing behind a proxy. I set the proxy via this: https://jjasonclark.com/how-to-setup-node-behind-web-proxy

However I seem to still have issues connecting when doing the install. I also have my http_proxy and https_proxy environment setup as well.


#8

tern is installed with git url “git://github.com/cloud9ide/tern_from_ts.git#84d51dcb9b16b126a206789d4d4237cde2801fe4” see https://github.com/c9/core/blob/master/package.json#L37


#9

Hopefully this will fix that:

git config --global url.https://github.com/.insteadOf git://github.com/


#10

I R CONFUSED… Root can’t access… wait… what? IT can’t access root?


#11

editing the package.json file seems to have fixed some issues.

Changed all git:// URLs to https:// URLs


#12

Still get a few that fail to connect. Gotta look into those more closely. Haven’t seen the permission issue since i did chmod 777 c9sdk

Crosses Fingers


#13

Fixed. The following command fixes all things:

git config --global url.https://github.com/.insteadOf git://github.com/