Ruby on Rails generate command porblems

rails
ruby

#1

Hi, I’m using cloud9 as suggested in a Rails tutorial: https://www.railstutorial.org/book/toy_app
but when I use the command generated scaffold system remains firm and after several minutes nothing happens.


"rails generate" from Hartl Rails Tutorial Ch 3 just hanging up in terminal
#2

What command are you typing? Can you paste your terminal output. Also are you sure it didn’t create any new files? Have a read further and see if it generated the files it mentions.


#3

The command is:
rails generate scaffold User name: string email: string
And i haven’t output from console and any file generated.


#4

I have the same issue. Same command, no output as the cursor just hangs.


#5

I had the same issue, this is what I did to resolve it, type the following into the terminal:

spring stop

Once the terminal indicates that Spring has stopped, rerun your command,

rails generate scaffold User name: string email: string


#6

I have the same issue. I have tried spring stop. I have tried ctrl-C
I have tried running rake and migrate before running rails generate scaffold User name: string email: string
Still nothing, it is lagging.

Any suggestions?


#7

I experienced the same issue. Running:

$ rails g uploader picture

left the cursor hanging indefinitely with nothing being generated.

Following M. Hartl’s advice about Spring processes (Box 3.4 Unix processes) resolved it. Running:

$ ps aux | grep spring

returned:

ubuntu      3271  0.0  0.0 569224 16672 pts/6    Sl   01:11   0:00 spring server | mh03_sample_app | started 3 hours ago                               
ubuntu      9265 94.3  0.1 468460 73160 ?        Rsl  04:20   0:02 spring app    | mh03_sample_app | started 2 secs ago | test mode

Killing the spring server:

$ kill -15 3271

and re-running:

$ rails g uploader picture

now generated the uploader.