Ruby 1.9.3 DEPRECATION WARNING - how do I update?

ruby

#1

Hi
I’m getting this message when I run scss:

DEPRECATION WARNING:
Sass 3.5 will no longer support Ruby 1.9.3.
Please upgrade to Ruby 2.0.0 or greater as soon as possible.

I’m not a ubuntu guy but I’ve tried to update Ruby and I think I’ve succeed except I’m still seeing this warning when I run scss

csixtyfour:~/workspace $ scss -v
DEPRECATION WARNING:
Sass 3.5 will no longer support Ruby 1.9.3.
Please upgrade to Ruby 2.0.0 or greater as soon as possible.

Sass 3.4.22 (Selective Steve)
csixtyfour:~/workspace $ ruby -v
ruby 2.3.0p0 (2015-12-25 revision 53290) [x86_64-linux]

#2

Please do your best to search the community before creating a new topic. Just want to keep things organized :slight_smile: :point_right: How to upgrade ruby.


#3

#4

I’ve already tried rvm use

csixtyfour:~/workspace $ rvm use 2.3
Using /usr/local/rvm/gems/ruby-2.3.0
csixtyfour:~/workspace $ scss -v
DEPRECATION WARNING:
Sass 3.5 will no longer support Ruby 1.9.3.
Please upgrade to Ruby 2.0.0 or greater as soon as possible.

Sass 3.4.22 (Selective Steve)

but I still get the same message


#5

#6

SCSS is in our shared tools for the UI. We’ll get the ruby version used there updated soon. Please ignore the warning for now.

Alternatively, install your own version of scss via gem and the system will prefer that over our built-in one.