Requesting Help with Disk Space Full Error


#1

Hello,

While trying to switch from SSL Endpoint to Heroku SSL, I ran multiple commands to switch over. Since my heroku-cli was out of date, I ran ‘heroku update’. When this didn’t work, I ran ‘apt-get install heroku-toolbelt’, which did not help either. After a few more ‘heroku version’ and ‘heroku update’ commands, I began to get disk space errors. At the suggestion of a Heroku employee, I ran ‘sudo apt-get install heroku-toolbelt’. To clear up these disk space errors, I tried running ‘sudo rm -rf /tmp/*​’, but this didn’t seem to help.

After I restarted my Cloud 9 workspace, it has been unusable (I can no longer use the command line). I did read somewhere that running ‘apt-get upgrade’ can use all available space, and I might need to make a new workspace.
I don’t expect cloning this workspace would work, and getting back to a working state seems like it would be a lot of work. Do you have any suggestions?

Please let me know if you need any more information. Any help here would be much appreciated as I’m entirely stuck. Thank you!


#2

Please see Ncdu: deleted /tmp, hdd remains full, you can use du to find what is taking most space, and then can delete or uninstall some of unneeded files. Cloning won’t help since new workspace will have exactly same files.


#3

Unfortunately, I am unable to write anything in my terminal, so I’m unable to run any commands at the moment. Could you temporarily free up some space, or is there another option?


#4

what is the url of the stuck project?


#5

https://ide.c9.io/neshapiro/weddingwebsite-cloned


#6

I have removed some of tmp files from your workspace so now it should work.
Why were you unable to type into your terminal, did it show any errors?


#7

I am now able to use my workspace again, thank you!

I still haven’t been able to switch over from SSL Endpoint to Heroku SSL, but I’m working with the Heroku team to resolve the issue I’m running into with opening a lock.

The terminal would not allow input, and the only messages I was seeing were due to the full disk issue. If I remember correctly, the terminal first messed up after i tried running the " sudo rm -rf /tmp/*​ " command to clear out tmp files. I then tried closing that terminal and opening a new one, followed by restarting my workspace.

This is what the terminal looked like (without the loading icon, I gave it ~20 minutes to load)