Remote SSH workspace - Error

ssh
workspace

#1

I get the following error:

Could not execute node.js on root@example.com module.js:340 throw err; ^ Error: Cannot find module ‘/root/String.fromCharCode(10)+process.version’ at Function.Module._resolveFilename (module.js:338:15) at Function.Module._load (module.js:280:25) at Module.runMain (module.js:492:10) at process.startup.processNextTick.process._tickCallback (node.js:244:9) Warning: Permanently added ‘example.com’ (RSA) to the list of known hosts. Connection to example.com closed.

Have changed my domain to example.com in above.

I am running v0.8.15 & npm 3.10.8

I have specified the node path and tried it without path and same thing. It runs locally on my server though.

Running fedora 15


#2

Is there anyway to set the path for node_modules to /root/node_modules?


#3

it appears there is a regression in our support for node versions older than 0.10, (we started using -p flag which, turns out, was added only in node 0.10)

To install cloud9

Install tmux (1.8 or newer) by running sudo yum install -y tmux
run curl -L https://raw.githubusercontent.com/c9/install/master/install.sh | bash to install dependencies from https://github.com/c9/install

use ~/.c9/node/bin/node as node path.