Reload application doesn't reflect latest code


#1

Hi, I am writing an Angular2 web app, and I followed the process above but using my own TypeScript that runs fine in my local machine. The problem is that after the first load of the webpage, reloading does not reflect changes in my code in my C9 console ( I saved the changes in the file and the mapped js file reflects the changes). I tried repeating "npm install/npm start " again. Also I restarted the browser !. Any hints ? thanks.


Getting Started with AngularJS
#2

What exactly do you mean when you say:

I’m assuming you’re referring to the text editor but want to make sure. Also, you’ve tried restarting your workspace and restarting Apache to force the changes to be detected?


#3

restarting Apache worked for me. Thanks.


#4

I have the same issue with some of my workspaces, cloning doesn’t resolve the issue, restarting apache after every single change is not an option or a solution, at best a workaround – but not a good one :wink:

Any ideas?


#5

Now, that was quick… figured it out, after all, it was opcache…

This post helped:

Somehow, on my instance, apache loads /home/ubuntu/php.ini instead of /home/ubuntu/workspace/php.ini
or /etc/php/7.2/apache2/php.ini

Thats wired because the cli uses the php.ini from worskpaces

$ php -i | grep php.ini                                                                                                                                                     
Configuration File (php.ini) Path => /etc/php/7.2/cli
Loaded Configuration File => /home/ubuntu/workspace/php.ini

Now /home/ubuntu/php.ini has some strange (production) opcache configuration inside:

Solution:
I changed the following values:

# /home/ubuntu/php.ini - old values:
opcache.memory_consumption=128
opcache.max_accelerated_files=4000
opcache.revalidate_freq=60

to;

# /home/ubuntu/php.ini – new values:
opcache.memory_consumption=256
opcache.max_accelerated_files=10000
opcache.revalidate_freq=2

Reload apache and it works.