Reconfiguring, and Running Gitlab on cloud9 ide

gitlab
git

#1

Trying to set up a gitlab instance on a C9 workspace, I have set up gitlab previously on physical machines and was expecting the same ease of install, but it keeps hanging.

It is hanging on this:

  • ruby_block[supervise_redis_sleep] action run

After a quick look online this comes up: Gitlab Common Installation Problems

But this does not resolve the issue. Has anyone installed gitlab successfully on a C9 workspace? Am I missing something?

Regards
Matt


#2

The configure step looks at uname which is currently 4.2.0-c9 when for normal ubuntu it is 4.2.0. This denotes the kernel version and it may be tripping up the embeded runit cookbook they use.

This is just off the top of my head, and I don’t know of a fix at this time. I’ll do some digging after I finish a couple of tasks this morning.


#3

Without exiting the terminal that you ran sudo gitlab-ctl reconfigure open a new terminal tab and run the following

sudo cp /opt/gitlab/embedded/cookbooks/runit/files/default/gitlab-runsvdir.conf /etc/init/
sudo initctl start gitlab-runsvdir

The first terminal tab will continue the reconfigure after you run the sudo initctl start gitlab-runsvdir in a new terminal tab.

This is because it looks like the ubuntu version used in the c9 ide (inside a docker) uses upstart instead of SysV init. Also gitlab will not start on startup due to this so you will manually have to start it up using the dual tab approach.


#4

It doesn’t seem to have any effect.


#5

Hmmm I was able to kick it off and complete the reconfigure. If you nano that conf file it will tell you where the executable is. In the second terminal if you start the executable manually using sudo ./path/to/file does that kick it off?


#6

I just tried this and I could not get it working. But running this command did work sudo /opt/gitlab/embedded/bin/runsvdir-start&

With ref - https://gitlab.com/gitlab-org/omnibus-gitlab/issues/191


#7

I did try it in a local ubuntu vm just to see if I could get it to finish and it did but took a long time to get there. I had to reboot it at one point because despite the disk usage, it just seemed to be frozen or stuck at one task… Locking up the rest of my computer as a result. Once it finished and I could open the login page, the default password wouldn’t work. lol Of course, I don’t have a way to send emails from the vm so I shut it down and left it.


#8

I have to set the external_url = "c9-url:8081" as for some reason listening on port 80 wouldn’t load gitlab.

Would it be possible to add gitlab to the list of preconfigured workspaces?

Is there a way to open port 22 for ssh for the ability to push repo’s using ssh?


#9

Haha that’s exactly what I meant for you to do! Glad it worked!


#10

I have set the SSH port to 8082 hoping that may enable me to push to it by using git remote add origin ssh://git@workspace.c9users.io:8082/project/app.git

But I get instant ssh_exchange error… I tried setting iptables but it says that command is not found and ufw is not running, so not sure what is blocking it.


#11

I had to do it few times /opt/gitlab/embedded/bin/runsvdir-start& whenever it was locked