reCaptcha Issue


I’m trying to set up an account, but I can only get as far as the reCAPTCHA. I click the pictures, but I keep getting the following error:

Invalid captcha code

I’ve tried in both chrome and firefox.


I’m having the same issue. I didn’t get the captcha popup in Safari and then when I switched to chrome I would see it and submit valid answers and then get a captcha error when I click the button to create the account even though I have a verified captcha. See screenshot:

I’m just trying to set up this account so that I can continue along with the Michael Hartl Rails tutorial. At this point I’m blocked just trying to sign up for Cloud 9.


Off topic, but I am actually looking at that EXACT tutorial right now. I wonder if that’s at the root of this.


I don’t see how the tutorial is related to this signup problem.


Right. It’s clearly not. I just thought it was funny. Back to business, then…


I am also having this issue where I can not get past the reCaptcha. I enter my CC information, complete the reCapatcha and then it gives the error "server returned an error: invalid captcha code. I’m not a robot!


I’ve also been having this error for a few hours now. Somebody recommended Cloud9 to me and I can’t sign up! :frowning:


My students are having the same issue. This worked earlier this week, but not today. I’ve had a great experience with Cloud9 so far, hopefully this is fixed quickly.



Really sorry for the issues here. There’s a problem with signups at the moment and we’re working on releasing a fix right away. Please check out (and possibly subscribe to) to get live updates about the issue and it’s resolution.



I had to start the create account process from the beginning, but the issue seems to be resolved.


I’m reading an incident resolved message regarding this on the Status page, but I am still unable to create an account as of 30 seconds ago. Tried multiple times.


Still getting this issue; still unable to join.


Hi Ryan,

This is a different issue. According to the error message, there’s a problem while processing your card. Can you check if the information you’ve added for the credit card matches exactly with the information in your bank. And if so, please contact your bank to check if they’re refusing our payment processor’s request for validation.



Signup problem, no captcha show when creating new accout
closed #14