Random code deletion


#1

When I’m trying to edit a file, suddendly all it’s content disappears. I dont even know what’s happening.


All open files deleting content and loosing 3 hours of saved work - Cloud 9 for Salesforce IDE (using C9 file history)
#2

We can definitely take a look at this. Can you let me know what exactly what was happening when this occurred? It might be tough to tell what caused it but any info is useful.

  • Was it just you in the workspace or were other people using it as well?
  • Did you have the IDE open in any other browsers or on any other machines?
  • What workspace did this happen in?

#3

Also what file/s in what workspace is this happening in?


#4

There was another person using the workspace when it first happened, but I tried using it alone and it still happened.
I tried connecting my own account on 2 machines and it happened too. It happened here: https://ide.c9.io/salk0/redes
Thanks in advance.


#5

Its happening in this workspace: https://ide.c9.io/salk0/redes
Files are:
workspace/AEDII/aed2/KaratsubaOfman/main.cpp
workspace/AEDII/aed2/KaratsubaOfman/main3.cpp


#6

I am experiencing this problem in this workspace https://ide.c9.io/sandikbarr/giphy-club in the index.html file. Several of us were sharing the workspace earlier today, but now everyone else should be signed out. It seems to happen whether only one person has the file open or multiple people do. When I cat the file on the command line, the contents are still there, but it shows blank and unsaved on the editor. Contents are disappearing within a minute of having it open.


#7

I am having a similar issue. Had 6 or so *.cls files and *.trigger files open in Salesforce C9 for Salesforce and poof all the files went blank, gave me EOF errors on each. File history revealed versions current about 3 hours before vanishing act, but code saved in that window is gone…

https://ide.c9.io/kurtfairfield/vks_delphix_sandbox_full


#8

I’m experiencing the same issue from time to time. I usually use 2 browser windows: one for editing and the second one for the terminal shells.

It happens when I open the second window having tabs with open files. It seems that it’s definitely something related to the Collaboration features. It shows an orange mark with my user name at the top of the file and the code disappears suddenly.

The file itself doesn’t change. You can recover it using a terminal editor, or copy it into another file. It also works the "File History’ feature to recover previous versions of the file. :heart_eyes: (I discovered that feature thanks to this issue)

Usually, it stops deleting the code just ‘reloading’ the second window in the browser.


Code disappearing