'rake db:migrate' fails. 'install bundle' also fails

ruby

#1

Hi. I ran ‘rake db:migrate’ and got the following message:

Could not find json-1.8.1 in any of the sources
Run `bundle install` to install missing gems.

So I ran ‘bundle install’ but it was unable to install json, (which I guess is needed for ‘rake’).
Can anyone help me?

An error occurred while installing json (1.8.1), and Bundler cannot continue.
Make sure that `gem install json -v '1.8.1'` succeeds before bundling.

#2

I was able to fix this problem. I copied the Gemfile and Gemfile.lock from an older (known good) installation of my project into my new (problematic) project.

That fixed it!