Rails server error message


#1

Hi, I’m using ruby on rails in Cloud 9, whenever I’m running the server, I have a message appearing at the top:

“/usr/local/rvm/gems/ruby-2.3.0/gems/activesupport-4.1.0/lib/active_support/values/time_zone.rb:285: warning: circular argument reference - now
=> Booting WEBrick
=> Rails 4.1.0 application starting in development on http://0.0.0.0:8080
=> Run rails server -h for more startup options
=> Notice: server is listening on all interfaces (0.0.0.0). Consider using 127.0.0.1 (–binding option)
=> Ctrl-C to shutdown server
[2016-08-04 11:38:40] INFO WEBrick 1.3.1
[2016-08-04 11:38:40] INFO ruby 2.3.0 (2015-12-25) [x86_64-linux]
[2016-08-04 11:38:40] INFO WEBrick::HTTPServer#start: pid=3681 port=8080”.

The server seems working though but I’m afraid that if I don’t fix this minor prob it can get bigger later on.

Thanks for your help

Regards


#2

I don’t see any error messages, I think your server is running fine.


#3

Thanks for your reply, actually I bothered by the first line:

usr/local/rvm/gems/ruby-2.3.0/gems/activesupport-4.1.0/lib/active_support/values/time_zone.rb:285: warning: circular argument reference - now

This appear not only when I run the server but for each action I make in the console so I don’t know what it means and if this can be a problem later on.

Thanks for your help


#4

I am also getting a similar message when I run rake spec command:

/usr/local/rvm/rubies/ruby-2.3.0/bin/ruby -I/usr/local/rvm/gems/ruby-2.3.0/gems/rspec-core-3.5.1/lib:/usr/local/rvm/gems/ruby-2.3.0/gems/rspec-support-3.5.0/lib /usr/local/rvm/gems/ruby-2.3.0/gems/rspec-core-3.5.1/exe/rspec --pattern spec/\*\*\{,/\*/\*\*\}/\*_spec.rb

However, I do not get this message when I try to run the Rails server.

Maybe @bradydowling or @timjrobinson can add some insight on what this means?


#5

We don’t have much experience with ruby unfortunately. I’m not sure what that warning means and it doesn’t seem Cloud9 related. You’d probably have more luck posting this on Stack Overflow.


#6

I am getting the same error message. I can not figure this out…Running this command, I get the below message:

$ bundle exec rake db:migrate
/usr/local/rvm/gems/ruby-2.2.1/gems/activesupport-4.1.0/lib/active_support/values/time_zone.rb:285: warning: circular argument reference - now
== 20170608180952 CreateContacts: migrating ===================================
– create_table(:contacts)
rake aborted!
StandardError: An error has occurred, this and all later migrations canceled:

SQLite3::SQLException: table “contacts” already exists: CREATE TABLE “contacts” (“id” INTEGER PRIMARY KEY AUTOINCREMENT NOT NULL, “name” varchar(255), “email” varchar(255), “comments” text, “created_at” datetime, “updated_at” datetime)